Cross-platform FlySight Viewer

From FlySight
Revision as of 21:12, 16 January 2017 by WikiSysop (Talk | contribs)

Jump to: navigation, search

Downloading the New FlySight Viewer

The new cross-platform FlySight Viewer is available for Mac or Windows:

Windows Download
Mac Download
Source code GitHub

On Windows, just unzip the downloaded file and move the extracted folder to a convenient location.

On a Mac, open the downloaded drive image and copy the FlySightViewer application to a convenient location (usually your Applications folder).

Changing Settings

You can change settings by going to File > Preferences on Windows or going to FlySightViewer >> Preferences on a Mac. You may want to go to the settings right away to choose whether you will use metric or imperial units.

The Main Window

The main window for the FlySight viewer looks like this:

MainWindow.png

The Plot View

At the top is the Plot View. This shows a plot of data from your jump. You can turn plots on or off by choosing from the Left menu or by using keyboard shortcuts shown to the right of each item in the menu. You can also change the bottom axis by selecting from the Bottom menu.

Below the Plot View are several dockable windows. You can drag these windows away from the edge of the main window to undock them or drag them back to the edge of the main window to dock them again.

The 3D Views

The first three dockable windows are the Side View, Top View and Front View. These show three views of your jump. The Top View is always shown from the top. The Side View, drawn in blue, is shown from the direction of the blue dot. The Front View, drawn in red, is shown from the direction of the red dot.

You can rotate the Top View (and change the direction of the other views) by clicking and dragging left-to-right in the Top View. This can be used, e.g., to line up the other two views with a swoop so that one is the front view and the other is the side view. When you rotate the Top View, the arrow will always point north.

The Map View

Finally, on the right we have the Map View. If you have an internet connection, this will show an aerial view of your flight with a Google Maps underlay. The usual controls for Google Maps can be used here. In particular, you can use the drop-down menu in the top right of the window to show a map, terrain, a satellite photo etc.

Links between the views

When you move the mouse over a location in any of the views, the same location will be marked in the other views. This can be very useful, e.g., in connecting a change in speed to a particular location or manoeuvre.

Importing a Track

To import a track from your FlySight, go to File > Import Track. Locate the track you want to import. If you are importing from a FlySight, it should show up as a drive. The jumps are organized in folders by date and each file is named with the time at the start of the log.

Panning the Plot View

Once you've imported a track, you may want to pan and zoom in the Plot View. To pan, check that Pan is selected in the Tools menu or hit P to switch to pan mode. Then click and drag in the Plot View to move the view. If you're zoomed all the way out, this won't do anything.

Zooming the Plot View

To zoom, check that Zoom is selected in the Tools menu or hit Z to switch to zoom mode. Clicking and dragging in the plot view will select an area of the plot. Releasing the mouse button will zoom to that area. Alternatively, use the mouse wheel or the "scroll" gesture on a track pad to zoom in and out. The mouse wheel and scroll gesture can always be used to zoom in/out regardless of the currently selected tool.

Measuring in the Plot View

To make measurements in the plot view, check that Measure is selected in the Tools menu or hit M to switch to measurement mode. Clicking and dragging in the plot view will measure the difference in the plotted values from the start to the end of the drag.

Importing a Gate

You can also use the FlySight to mark stationary objects like gates for swooping. To do this:

  1. Edit the "config.txt" file on your FlySight and change the Model option to 2. This will optimize the FlySight for recording stationary points. More information on configuring your FlySight can be found here.
  2. Place your FlySight on or near the object you want to mark, then turn it on. Wait for the green light to start blinking then wait another 30 seconds or so. Turn the FlySight off. You now have a log file which records the position of that object.
  3. Open the FlySight Viewer and go to File > Import Gate. Locate the log file you just recorded.

Once these steps have been completed, the FlySight Viewer should show a small "+" symbol at the position you logged.

Importing a Video

Videos can be imported into the FlySight Viewer and synchronized with the data. Once the video is synchronized, it acts like the other views--moving the mouse over a point in one of the other views will move the video to that frame. While a video is playing, the current position will be marked in the other views.

To import a video, go to File >> Import Video. Locate the video you want to import. This should open a video window like this:

VideoView.png

To play the video, click the play/pause button. Click it a second time to pause the video. To seek to a different position within the video, click and drag the slider at the bottom of the window or use the mouse wheel or scrolling gesture while the cursor is on top of the slider. Use the dial on the right to move by small increments. Click and drag to move the dial or use the mouse wheel or scrolling gesture while the cursor is on top of the dial.

To synchronize the video and data, you will need to find a point which you can identify in both. For example:

  • Exit can usually be identified in both the data and the video. However, it can be difficult to pick out the exact frame in which exit takes place, so this is often not very accurate. If you use the exit for synchronization, you will most likely find that it is easier to find the exit in the Plot View by looking at horizontal speed. At exit, horizontal speed will drop off rapidly, but vertical speed will pick up relatively slowly.
  • Another possibility is the moment you stop moving after you land. It is usually possible to pick out almost exactly the point when you stop moving on video, and this moment is usually pretty definitive in the Plot View as well.

Once you've chosen a point to synchronize, find it in the video using the controls mentioned above then click the Set Exit button. You should see the time indicator jump to "0.000 s" when you click the button.

Next, find the same moment in the Plot View. Choose Set Exit from the Tools menu or hit X, then click on the exit in the Plot View. The "zero" at the bottom of the plot should move to the location you clicked.

Exporting the Plot

The data in the Plot View can be exported to a CSV file. The data can then be imported, e.g., into Excel, where you can perform analysis that is not currently possible in the FlySight Viewer. To export, first ensure that the Plot View is zoomed to the data you want to export and that the appropriate values are being displayed. Then go to File >> Export Plot. Once the file is exported, double-click on it to open it in Excel. From here, you can create plots, analyze the data, etc.

ExportPlot.png

Exporting to KML

The track itself can be exported to a KML file, which can be viewed in Google Earth. To export to KML, first zoom in to the area you want to export. Then go to File >> Export KML. Once the file is exported, double-click on it to open it in Google Earth.

ExportKML.png

Wind Estimation and Adjustment

There are a couple of video tutorials which cover wind estimation and adjustment:

Wind estimation View
Wind adjustment View

The wind estimation tools take advantage of the fact that when an aircraft is flying at constant airspeed in constant winds, no matter which direction it points, its velocity vector will sit somewhere on a circle whose center is the wind velocity and whose radius is the speed of the aircraft. An example might help to see how this works. Here is a plot of 2D velocity for a typical climb to altitude:

ClimbToAltitude New.png

To show the Wind View, go to Window >> Wind View. This is an unusual way to look at a flight. What we're seeing here is the aircraft's velocity plotted for each point in the log. Notice that the track forms a fairly clear circle. We can overlay the best fit circle on this plot:

ClimbToAltitudeWithFit New.png

The center of the circle tells us the wind speed and direction, while the radius of the circle gives us aircraft speed.

To save this wind data to preferences, click the Save button. This will store the wind estimate in the FlySight Viewer's preferences. To view the currently saved wind estimate, go to File >> Preferences then switch to the Wind page:

WindPreferences.png

To adjust the data using the saved wind estimate, go to Tools >> Wind Adjustment or hit the W key. A small indicator will show up in the top-right of the main plot to tell you that you're viewing adjusted results. Any result which depends on horizontal speed will be affected by this change.